読者です 読者をやめる 読者になる 読者になる

Sublime Text2を使ってRubyを実行するとき

ターミナルからruby hoge.rbでは実行できるのに Sublime Text2でBuildして実行すると

'require': no such file to load --hoge hovge

ってエラーがでた。

homebrewでインストールしてるバージョンのrubyを使ってないんかなと思い
調べてみたらビンゴだた。

Preferences.sublime-settingsにパスを設定せなあかんのね。

    "build_env":
    {
        "PATH":"hoge hoge hoge..."
    },

WindowsのSublime Text2でビルドする場合は、
Ruby.sublime-buildのencodingをcp932で設定せなあかんかったし、
設定につまづいた一日だった。

ってか、ほんと、会社のPCをMacにしたい。
せめて自分のMacからリモートで仕事させて欲しい。